Try New Technology

Author Archive

Blocking Roku (and other TV) Ads

by on Jun.11, 2022, under Techie

History: Roku ads got annoying so I looked into blocking them. After reading multiple posts I was able to put together a complete solution for my setup.

First was to create a free account at NextDNS.io, then login and follow the directions to setup DoH on my router.

NOTE: The Mikrotik instructions are as follows (they offer instructions for most OS, browsers, and many routers):

/tool fetch url=https://curl.se/ca/cacert.pem
/certificate import file-name=cacert.pem
/ip dns set servers=
/ip dns static add name=dns.nextdns.io address=45.90.28.0 type=A
/ip dns static add name=dns.nextdns.io address=45.90.30.0 type=A
/ip dns set use-doh-server=“https://dns.nextdns.io/abcd1234” verify-doh-cert=yes

On NextDNS.io I added the following items:

  1. Privacy > Blocklists: Lightswight05 – Ads & Tracking
  2. Privacy > Native Tracking Protection – Roku, Samsung, Apple
  3. Denylist – *.wwwimg.roku.com
  4. Denylist – *.amoeba-plus.web.roku.com

NOTE: Once this was done you can see in the Logs that everything is was working. Looking at my Roku TV main screen, there was a blank area where the ads should be.

The last thing I did to make the most of this filtering was to add the following rules to my Firewall > NAT which ensures any device inside the network trying to access an external DNS server (via UDP/TCP port 53) was redirected to the router and through this DoH service:

/ip firewall nat add action=dst-nat chain=dstnat comment="dns redirector (udp)" src-address=192.168.1.0/24 dst-port=53 protocol=udp to-addresses=192.168.1.1
/ip firewall nat add action=dst-nat chain=dstnat comment="dns redirector (tcp)" src-address=192.168.1.0/24 dst-port=53 protocol=tcp to-addresses=192.168.1.1

Reference that I used to piece this all together:
https://jasonpearce.com/2020/09/16/how-to-disable-ads-on-the-roku-home-screen/
https://forum.mikrotik.com/viewtopic.php?t=133896N

Comments Off on Blocking Roku (and other TV) Ads more...

Create file with full directly listing (Linux)

by on Sep.06, 2020, under Techie

If you need a full listing of all the files in a folder saved to a file then use the following from a shell:

'ls' > file_list.txt

NOTE: In this case the file_list.txt file will be listed in the file_list.txt file, and to avoid this, just save the file_list.txt file to a different location than you are running the ‘ls’ command in.

Comments Off on Create file with full directly listing (Linux) more...

Backing up folder with symlinks in it

by on Sep.06, 2020, under Techie

If you need to backup a folder with symlinks and keep them intact use the following from the shell:

tar -csf folder.tar /folder/location/with/symlinks/

Comments Off on Backing up folder with symlinks in it more...

USB Keyboard and/or Mouse stops working once Windows loads (work fine during POST)

by on Dec.22, 2019, under Techie

This is a fun issuer I can into, but gladly I had the keyboard working on the Windows 7 computer that I was fixing. This can be caused by the “Allow the computer to turn off this device to save power” setting being Enabled in Device Manager. Below is a direct copy (Click here for the Original Post) from the Microsoft Community discussion that solved this issue, but be warned it has solutions that involve editing the registry (doing so incorrectly can cause serious issue with Windows) so you should always backup the registry before starting any changes in the Windows registry (See Microsoft KB 322756 for more information):

Perform these steps and check if it helps.

  1. Click Start, type Device manager in the Search box and then click Device Manager from the returned list
  2. Click to expand USB Root Hub and click the Power Management tab
  3. Uncheck the option to Allow the computer to turn off this device to save power and click OK

Note: You may see multiple listings for USB Root Hub, uncheck this option for all USB Root Hubs.
Close the Device Manager

Advance steps would be modifying the registry.

  1. Click Start
  2. type regedit in the Start Search box, and then click regedit in the Programs list.
  3. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Executive
  4. In the details pane, right-click AdditionalCriticalWorkerThreads, and then click Modify.
  5. In the Value data box, type 2, and then click OK
  6. Note You can specify a value that is between 1 and 16.
  7. Exit Registry Editor.
Comments Off on USB Keyboard and/or Mouse stops working once Windows loads (work fine during POST) more...


Looking for something?

Use the form below to search the site:

Still not finding what you're looking for? Drop a comment on a post or contact us so we can take care of it!

Visit our friends!

A few highly recommended friends...